Results 1 to 12 of 12

Thread: Tutorial: Unable to Initialise the Graphics in Windowed Mode (Fix)

  1. #1
    M.C.F.C is offline Hot Prospect for the Future

    Join Date
    31-03-19
    Posts
    141

    Tutorial: Unable to Initialise the Graphics in Windowed Mode (Fix)

    Problem



    Spoiler!


    Solution

    1) Right-click cm0102.exe > Properties

    2) Compatibility > Change High DPI Settings

    Spoiler!


    3) Change settings as below

    Spoiler!
    Last edited by M.C.F.C; 14-05-20 at 12:02 PM.

  2. The Following 4 Users Say Thank You to M.C.F.C For This Useful Post:


  3. #2
    bine ye is offline Hot Prospect for the Future

    Join Date
    23-03-12
    Location
    An Dún, Éire
    Posts
    187
    I had this problem about 6 months ago and while most reported success with the above steps, this did not work for me. What I had to do was open the cm0102_GDI.exe, this should load fine. Then when on the initial settings, set to "Windowed" and save. Then you can quit and load the normal (or patched) cm0102.exe without any issues.

  4. #3

    Join Date
    13-01-20
    Posts
    156
    I had this problem too and went into display settings, changed from 125% (recommended) to 100% and it worked a treat, just a pain changing it over every time!

  5. #4
    M.C.F.C is offline Hot Prospect for the Future

    Join Date
    31-03-19
    Posts
    141
    Quote Originally Posted by bine ye View Post
    I had this problem about 6 months ago and while most reported success with the above steps, this did not work for me. What I had to do was open the cm0102_GDI.exe, this should load fine. Then when on the initial settings, set to "Windowed" and save. Then you can quit and load the normal (or patched) cm0102.exe without any issues.
    If it works...

    Quote Originally Posted by MaxiShagilko View Post
    I had this problem too and went into display settings, changed from 125% (recommended) to 100% and it worked a treat, just a pain changing it over every time!
    I was doing this as well until I found out about this option.

    I even had a batch script so that I clicked it once and it would do it for me automatically.

    Below code I ran to go from 150% zoom to 100% zoom.

    Code:
    @ECHO OFF
    
    explorer ms-settings:display
    ping -n 2 127.0.0.1 > nul
    
    :VBSDynamicBuild
    SET TempVBSFile=%tmp%\~tmpSendKeysTemp.vbs
    IF EXIST "%TempVBSFile%" DEL /F /Q "%TempVBSFile%"
    ECHO Set WshShell = WScript.CreateObject("WScript.Shell") >>"%TempVBSFile%"
    ECHO Wscript.Sleep 100                                    >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "{TAB 6}"                          >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "{UP 2}"                           >>"%TempVBSFile%"
    ECHO Wscript.Sleep 100                                    >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "%%{F4}"                           >>"%TempVBSFile%"
    
    CSCRIPT //nologo "%TempVBSFile%"
    
    EXIT
    Below code I ran to return from 100% zoom to 150% zoom.

    Code:
    @ECHO OFF
    
    explorer ms-settings:display
    ping -n 2 127.0.0.1 > nul
    
    :VBSDynamicBuild
    SET TempVBSFile=%tmp%\~tmpSendKeysTemp.vbs
    IF EXIST "%TempVBSFile%" DEL /F /Q "%TempVBSFile%"
    ECHO Set WshShell = WScript.CreateObject("WScript.Shell") >>"%TempVBSFile%"
    ECHO Wscript.Sleep 100                                    >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "{TAB 6}"                          >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "{DOWN 2}"                           >>"%TempVBSFile%"
    ECHO Wscript.Sleep 100                                    >>"%TempVBSFile%"
    ECHO WshShell.SendKeys "%%{F4}"                           >>"%TempVBSFile%"
    
    CSCRIPT //nologo "%TempVBSFile%"
    EXIT
    Edit the line in bold depending on your zoom. For example for starting at 125% zoom you'll change the UP 2/DOWN 2 to UP 1/DOWN 1

  6. #5

    Join Date
    13-01-20
    Posts
    156
    Thanks M.C.F.C, great solution

  7. #6

    Join Date
    05-09-20
    Location
    Clifton
    Posts
    1
    Thank you very much, just what I was looking for.

  8. #7

    Join Date
    08-07-20
    Posts
    6
    Quote Originally Posted by MaxiShagilko View Post
    I had this problem too and went into display settings, changed from 125% (recommended) to 100% and it worked a treat, just a pain changing it over every time!
    Thank you very nice and at the same time simple advice.

  9. #8

    Join Date
    05-10-20
    Location
    Indianapolis
    Posts
    2
    Quote Originally Posted by MaxiShagilko View Post
    I had this problem too and went into display settings, changed from 125% (recommended) to 100% and it worked a treat, just a pain changing it over every time!
    Advice thank you

  10. #9

    Join Date
    17-06-20
    Posts
    11
    Quote Originally Posted by MaxiShagilko View Post
    I had this problem too and went into display settings, changed from 125% (recommended) to 100% and it worked a treat, just a pain changing it over every time!
    How easy it is to solve this problem!

  11. #10

    Join Date
    05-11-20
    Posts
    3
    Can you write what you have done to solve the problem.

  12. #11
    Redknapp69 is offline Member of the Month
    Social Media Mod

    Join Date
    03-03-12
    Posts
    28,262
    Quote Originally Posted by harveyymmetcalfe View Post
    Can you write what you have done to solve the problem.
    read the first post in this thread?

  13. #12

    Join Date
    05-11-20
    Posts
    3
    I've already had such a problem. Have solved it in the same way.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •